Pages

2/25/2013

Configure NAT in the VRF lite scenario

Configure NAT in the VRF lite scenario
But, why would you do a VRF and then decide you wanted to route from that VRF to your global routing instance?  And why on earth would you want to NAT between two interfaces in different VRF's. 
Well, I did end up needing to and this article was very helpful.

ip vrf MyVRF
 exit

interface 
 (no switchport)           ! make routed port
 ip vrf forwarding MyVRF   ! associate interface with MyVRF
 ip address A.B.C.D M.M.M.M

interface 
 switchport
 switchport trunk encapsulation dot1q
 (switchport nonegotiate)
 switchport mode trunk

vlan 10
 name WAN-VLAN

interface Vlan10
 ip vrf forwarding MyVRF
 ip addr E.F.G.H M.M.M.M
 ip nat enable

! now the VRF-aware NAT config:
interface 
 ip nat enable

interface Vlan10
 ip nat enable

ip access-list standard LAN-to-NAT
 permit 

ip nat source list LAN-to-NAT interface Vlan10 vrf MyVRF overload

! finally the def. route
ip route vrf MyVRF 0.0.0.0 0.0.0.0 



2/12/2013

Openfiles

Openfiles: From the cmdline, query what files are open and disconnect them.
http://technet.microsoft.com/en-us/library/cc732490(v=ws.10).aspx

Windows 2008 Stuff

- Disable Hybernate on servers:  powercfg -h off
- RDP Sessions from CMD line if you register query.dll like this:  regsvr32 query.dll
query session /server:servername [enter]
reset session # /server:servername [enter]
-What files are open?  (anything more than query may require settings change & reboot.)
openfiles /query

Misc - Windows 7

Windows Key + [arrow keys] will manipulate the current window:   maximize, minimize, and snap it to the left or right

Active Directory Stuff


- list all the groups and the members in those groups
dsquery group -limit 0 | dsget group -members –expand
- list fsmo role holders
netdom query fsmo
- Show domain account policy
net accounts
- Start AD synchronization
repadmin /syncall
- Group policy troubleshooting
gpupdate /force => reapply group policy now
gpresult => show what policies apply

Microsoft Network Stuff

- built in sniffer...
netsh trace start capture=yes tracefile=c:\capture.etl
netsh trace stop
http://blogs.msdn.com/b/canberrapfe/archive/2012/03/31/capture-a-network-trace-without-installing-anything-works-for-shutdown-and-restart-too.aspx

- What groups am I a member of?
whoaim /groups

- reset interface IP configuration
netsh int ip reset all

- show all connections and refresh every 10 seconds
netstat –ano 1

VMware KB: Troubleshooting transaction logs on a Microsoft SQL database server

VMware KB: Troubleshooting transaction logs on a Microsoft SQL database server: Troubleshooting transaction logs on a Microsoft SQL database server
Prevent logs from filling up the server:
  1. Log in to the Microsoft SQL 2005/2008 Server as an administrator.
  2. Open up SQL Management Studio.
  3. Right-click the database that VirtualCenter is using.
  4. Click Properties.
  5. Click the Options link.
  6. Set the Recovery Model to Simple
  7. Click OK.
  8. Once this is complete, right click on the database again.
  9. Click Tasks>Shrink>Files.
  10. On the Shrink Database window select the file type as 'Log' . The file name appears in the filename drop down as databasename_log
  11. The space used versus the space allocated displays. After you set the recovery model to Simple, the majority of the space in the transaction log released.
  12. Ensure that the Release unused space radio button is selected.
  13. Click OK on this window to shrink the transaction log.